CWWK N100 NAS PCI Passthrough IOMMU Problems

Hello Proxmoxers :smiley:

I recently have built a NAS with this N100 board from CWWK and now I’m playing arround with Proxmox. I have two drives (Ironwolf 8TB) as a mirror vdev in a ZFS Pool from my previous TrueNAS setup connected to the onboard JMB585 SATA controller. I want to passthrough the whole controller to a TrueNAS VM running on the Proxmox host.

Going through the Proxmox Wiki for PCI Passthrough the (hopefully only) problem is the IOMMU isolation. All connected PCI devices are not assigned to a iommugroup ( they have the value -1 when running pvesh get /nodes/{nodename}/hardware/pci --pci-class-blacklist "".

When going throug the BIOS Settings trying to find the ACS (Access Control Services) entry I only found it accssible for the “external” PCI devices. The onboard ones are greyed out.

The only possible solution for this is to try using Alex Williamson’s ACS override patch as stated in the Proxmox Wiki. I tried to unterstand why this is possible dangerous but I don’t get it… Can anyone point me in the right direction?

Thanks in advance :slight_smile:

I have the CWWK N5105 board and followed this walkthrough - worked right away using Truenas Scale in a proxmox vm.
hdd passthrough

Thanks for your input, yeah i already have setup TrueNAS as VM with HDD passthrough this works so far but passing the complete pci controller seems having some advantages (e.g. control Power Management and S.M.A.R.T. from within TrueNAS)