Dell R810 - Proxmox VE installation of 8.2 always fails just before the end of installation

Hi guys

I have been trying to install Proxmox VE 8.2 on my vintage Dell R810 using a bootable USB stick made with Rufus 4-4 off the official 8.2 ISO.

I have checked the SHA256sum of my downloaded ISO and my ISO is binary exact and correct according to the site’s posted SHA256 checksum after being downloaded.

I have a Dell R810 with the PERC700 RAID controller, 6 SATA SSDs of 500GB each.

I run the ISO install and everything goes fine till just before the process should finish.

On multiple tries the install always fails on specifically two packages - sometimes it fails on

Installation of package proxmox-kernel.6-8-4-2-pve-signed-6.8.4-2_amd64_deb failed

and other times it fails on

Installation of nmap-common_7.93+dfsg1-1_all.deb failed

Always one of these two, always alternating. I have tried to install about ten times now over a space of two days.

If I open the debug window after the error above it DOES say the particular package is corrupt and cannot be extracted.

I have tried different flash drives from different manufacturers with different capacities - 4GB, 8GB and 16GB, all written with Rufus. All fail on either one of the above files at the tail end of the install process. I have tried both the R810’s front USB and rear USB slots, and worked my way through all of them.

I can take such a flashdrive that fails to install Proxmox VE 8.2 on this R810 (also written with Rufus) and put it in another Dell machine (my R820) and it installs Proxmox VE 8.2 there flawlessly, with no corrupt files.

The R810 has no problem with, for example, an Ubuntu 22.04 install via bootable USB - works perfectly off one of the same USB flashdisks that fails consistenly with Proxmox VE 8.2’s ISO specifically on the R810, in that case the Ubuntu 22.04 ISO was also written with Rufus 4-4 on on my Windows 11 desktop - just like the Proxmox VE 8.2 ISO was written.

Can anybody help as to why my Dell R810 absolutely refuses to install Proxmox VE 8.2 specifically, the installer always complaining about the same corrupt packages, across several different USB drives from different manufacturers, (I’ve tried Verbatim, Sandisk, Samsung, etc. etc. in 4, 8, 16GB capacities) and that same flashdisk works perfectly on a Dell R820 for installing Proxmox.

I have also destroyed and recreated the RAID on the R810, took out all drives except one physically (in case it was some kind of RAID issue) but if there is one drive, or the full six, the install always fails in the same way across all the different flashdrives from different manufacturers, in each USB port, front and back, on the R810.

Is the R810 simply incompatible somehow with Proxmox VE 8.2?

I guess I have good hardware since Ubuntu 22.04 installs flawlessly on the same R810, via USB…

I know there are a number of R810 users, so I don’t think that’s the problem.

I wonder if using the “install Debian and add Proxmox packages” method might succeed. At least if it doesn’t, you should have a way to better troubleshoot it with proper dmesg logs.

1 Like

I had an issue once where the PVE installer failed right at the very end of the install process, but it was with a 2018 Mac Mini with Apple’s T2 chip. It turned out that the boot loader was failing to install. I think I was able to reboot into the installer and switch over to a shell and manually run proxmox-boot-tool.

It was a very different set of circumstances, but could be you’re hitting something similar. Here’s a bit on the wiki about the bootloader: ZFS: Switch Legacy-Boot to Proxmox Boot Tool - Proxmox VE.

1 Like

Thanks for the reply! If I follow this route (and can manage to get Debian going on this hardware) will the end result be the same system as if installing direct from the 8.2. ISO? I intend to make this R810 my Proxmox backup machine, so I need to end up with a setup that is sufficiently “Proxmox” that I transparently deploy to / copy VMs from my R820 without hitting a snag with some incompatibility. E. g. my R820 is a “real” ISO based 8.2., does “Debian with packages” on my R810 mean the same exactly setup will result eventually?

Or close enough to be 100% compatibile.

Thanks again!


Thanks guys, I managed to get the Proxmox 8.1 ISO installed on this 10 year old Dell R810 with the PERC700H RAID controller. I’ll try to upgrade to 8.2 via APT now.

Some legacy R810s with the PERC700H RAID controllers are therefore not compatible with the current Proxmox VE 8.2 ISO, but DOES work with the Proxmox VE 8.1 ISO just fine.

After installing PVE 8.1 successfully from its ISO on my R810, I have now edited /etc/apt/sources.list and added

deb Index of /debian/pve/ bookworm pve-no-subscription

and after saving the change, did an

apt-get update;apt-get upgrade

and I now am running Proxmox 8.2.2 official successfully on my R810 where it WOULD NOT install from the Proxmox 8.2 official ISO.

So for my particular Dell R810 with the PERC700H RAID controller, it definitely works to install Proxmox VE 8.1 official ISO, then do an after-the-fact apt-get update;apt-get upgrade to get it to Proxmox VE 8.2.2 on that same hardware after editing /etc/apt/sources.list and adding the above line.

Good stuff, glad you got a fix.

As for the debian+packages method, as far as I know it’s completely the same as installing via the regular ISO. It changes the package sources as above, adds all the services, and then everything acts like it was installed with the official method. I’ve done it on one of my nodes and at this point, I couldn’t tell you which one anymore.

But sounds like you’ve gotten what you need so best of luck with the rest of it.

1 Like