I can't store a file with emojis on a Raspberry Pi running ZFS, but I CAN on TrueNAS

I am wildly confused about this.

I am trying to move my backup to a raspberry pi… But the I can’t move a certain file that contains a diamond emoji (:gem:). The issue is I can’t rename it at the source since it’s read only. I COULD just copy it over to somewhere else, rename it and upload it again but the issue is I don’t know how many of these files there are… And changing the name will probably screw something up later down the line.

Does TrueNAS use some special sauce for their ZFS or something…? How do I get emojis on the raspberry pi’s ZFS?

I know it’s not SMB or the raspberry pi itself since it works fine on an EXT4 partition. So it has to be ZFS right? I’m going insane…

What is the source filesystem where the emoji-file lives?

I suspect this has to do with utf8only and/or normalization settings on the target dataset.

To check, use zfs get utf8only pool/dataset in a terminal/console on TrueNAS. Do the same with normalization and check those settings.

I can’t tell you how to change it on TrueNAS, I think you’re only allowed to make changes via their webGUI and making changes through the CLI would possibly break things.