M.2 Stick killed my NIC

*edit, apologies for the one screenshot per reply below. Restrictions limit my account to one embedded image per post.

I am learning the hard way and I am new to Proxmox and Linux.

Config: I bought the components from a coworker and added the storage.
Proxmox PVE 8.1.3
CPU: AMD Ryzen Threadripper 2990WX 32-Core Processor
Storage: 1x 4TB Spinning Rust (hosting Proxmox 7.2.3)
3x 12TB Spinning Rust TrueNAS Storage
/sdb & /sdc are passthrough to TrueNAS.
/sdd is a recent add to move vms to while expanding /sda, then will be passed through to TrueNAS.

I installed the M.2 4TB NVME stick, deployed PVE 8.1.3 to said stick, bridged network to enp3s0 at install, and now no link lights on the switch. I know it’s not a physical layer problem because the link light does come on when the machine first power on. But once Proxmox starts to load the light goes out.

I have googled the S*** out of this and come up with a few potential causes.

  1. PCIe lD has changed after installing NVME stick? Not sure why this would matter since I installed a fresh new copy on the stick and setting it up for the first time? Screenshots attached.
  2. Wrong driver? I looked up the driver for the Aquantia AQC-107 (on MB) and the readme says “This driver supports Linux kernels >= 3.10, and includes support for x86_64 and
    ARM Linux system.”. The “ethtool --driver” output just says atlantic version 6.5.11-4-pve.
  3. NIC is down vs up? I ran the “ifup -v” command for that specific interface enp3s0 and I am not really sure what it was telling me so hopefully someone can tell me if this is important. I also ran “ip link set dev enp3s0 up” because I saw it in another post somewhere and still no joy.

If anyone has any direction to go and what commands to type or at least where I could find said commands, I would greatly appreciate your vectors!

P.S. probably already taken but considering a new call sign Smash Overide paying homage to…well IYKYK. I’m going with smash because thats about where I am at with this lol.

I found the problem. It was a combination layer two and layer eight problem. The cheap 10/100 garbage switch I had between my unifi switch and my machine was the problem. What was throwing me off is that my machine was working on that garbage switch before I wiped everything and started over. Lesson learned. Start from the lowest layer possible and never exclude layer eight possibilities.

For anyone that doesn’t get the joke about the layers…look up the seven layer OSI model of networking. There’s only seven layers. Layer eight would be the human screwing it up :wink: