No Proxmox GUI on Cluster

Hi guys, i posted this on reddit but it seems the sub is currently inactive, so here i am, i’ll just paste the original post i did :

Hi guys,

I am currently having issues with my cluster. I can access all 3 nodes on ssh but the GUI is not accessible, here is the message i get : PR_CONNECT_RESET_ERROR

It is not a brower issue since i can access another stand-alone pmx server that works fine on the same browser.

I also dont think it is a network one since everything is good in ssh, and the problem appeared after one of the nodes went offline, before that everything was fine, and i have not modified anything about network since then.

I have already tried restarting all services (pve-proxy pve-daemon, corosync etc) but this wasn’t succesfull, reboot also didnt work.

Here’s the wget command for that web gui, pls note that i had to modify the ip in the output since i cant post too many links here:

root@pmx11:~# wget --no-check-certificate “ip”

–2023-09-11 15:20:14-- “ip”

Connecting to ip… connected.

WARNING: The certificate of ‘[ip)’ is not trusted.

WARNING: The certificate of ‘[ip)’ doesn’t have a known issuer.

HTTP request sent, awaiting response… 200 OK

Length: 2159 (2.1K) [text/html]

Saving to: ‘index.html’

index.html 100%[=============================================================================>] 2.11K --.-KB/s in 0s

2023-09-11 15:20:15 (126 MB/s) - ‘index.html’ saved [2159/2159]


the command gives the same result on all nodes, so i dont understand why the gui isn’t working, maybe a certificate issue ?

Is there something i forgot, or do you have any idea where to look ?

Thanks, have a nice day,