Options to recover from corrupted metadata

I have a externally powered SATA backplane with 4 drive bays that attaches 3 hard disks, and 1 SSD (used as a cache) to my Ubuntu Linux computer via USB. The operating system sees each device as an external USB device. I have created a RAID-Z pool with all of the devices attached to this backplane.

This morning I was running a “scrub” when a rolling blackout occurred. When I rebooted, I got this message:

root@ubuntusys:/# zpool import
   pool: aquifer
     id: 5891443854XXXXXXXXX
  state: FAULTED
status: The pool metadata is corrupted.
 action: The pool cannot be imported due to damaged devices or data.
        The pool may be active on another system, but can be imported using
        the '-f' flag.
   see: https://openzfs.github.io/openzfs-docs/msg/ZFS-8000-72

        aquifer      FAULTED  corrupted data
          raidz1-0   ONLINE
            sdb      ONLINE
            sdc      ONLINE
            sdd      ONLINE

I have already tried zpool import -f -Fn, and it immediately comes back with the same error message.

According to ZFS-8000-72, this is a totally fatal error with no way to recover without some other backup (I have no other backup).

It is pretty incredible to me that a single power failure can completely nuke a previously healthy RAID-Z system. I have to be missing something here.

Is there really nothing I can do?