Strange network behaviour

Hi… thanks for reading.

My proxmox server stopped responding to ping requests from the local network, despite both my HAOS VM and Ansible LXC operating normally. This is a simple bridged network that has functioned fine for 6+ months.

I cannot ping the proxmox host from any device on my local network. I plugged a monitor into the NUC and am able to use the shell. From the shell, I can successfully ping the loopback, local address and other devices on the network. Ran ‘apt update’ and it worked as well.

The /etc/network/interfaces file matches the recommended settings as per the proxmox website.

I have tried:

  • Shutdown HAOS and LXC container and then rebooted NUC
  • ifdown / ifup on vmbr0
  • ifdown / ifup on en0
  • ifreload -a vmbr0
  • ifreload -a en0

Fortunately, I was able to backup both HAOS and the LXC container so worst case scenario, I can reinstall Proxmox.

But I figure this is a good opportunity to learn, so here I am. Any help or suggestions would be appreciated.

Not a lot to go on, but a couple ideas jump to mind:

  1. Did you set up Proxmox with a dynamic address? If it leased a new address , that would account for not being on the right place.

  2. How about the PVE firewall? Do you have that enabled? If so, are you allowing ICMP from the local network?

1 Like

Thank you! The pve-firewall was running, though I had not enabled it explicitly and everything was working before. This did the trick:

pve-firewall stop

Congrats—that’s awesome. For the record, I think having the host firewall enabled is generally a good thing. That might be a good place to do some future tuning. If you haven’t discovered them yet, Proxmox has some pretty decent docs: Proxmox VE Administration Guide.

Now that I know how easy it is to start/stop it from SSH, completely agree.

Just make sure you have an open ssh connection when you make changes! It’s really annoying when you realize you’ve just blocked ssh and have to find some other way to reset the box.