ZFSBootMenu saved my bacon... again

I know I’m preaching to the converted, but I thought I’d relate a story of what happened to me in the last couple of weeks.

I have my main working from home desktop which is an AMD Ryzen system with no integrated graphics. I have a separate Nvidia card, and I use the Nvidia proprietary drivers to do some gaming on Proton.

I run Ubuntu interim releases. As the window of upgrades was closing, I upgraded my 22.10 system to 23.04 with do-release-upgrade. The update resulted in an unbootable system. Rolled back to the last snapshot I had before the upgrade, and tried again. Same thing.

I did a separate clean installation of the LTS (22.04), and it booted fine. I then did a separate, clean installation of 23.04 and also booted fine. Weird but OK, something was borked in the upgrade mechanism.

Two weeks later I did some routine updates, and noticed that the Nvidia drivers were being updated. Next time I turned on the system, it was again unbootable. Never mind, revert to last working snapshot, try again. Same result. Some search-engine-foo revealed that there is a serious oopsie with the current Nvidia drivers, and a lot of people are experiencing an unbootable system after updating.

I’ve spent a couple of hours reading horror stories, which made me feel like sharing about how much I love my ZFS and also ZFSBootMenu.


Had a not dissimilar “upgrade” experience and convenient rollback to usable system with ZFSBootMenu.

Upgrade path then became fresh install of 23.04 on ZFSBootMenu, followed with Ansible to reinstall most my apps on a secondary system. Swap the drives then syncoid my home dir to the new system. Minimal downtime and fairly painless.


I use Ubuntu interim releases

Time was, those were rock-solid. Unfortunately, that time was about fifteen years ago. These days, yeah, if you’re going to rock the interim releases you DEFINITELY want ZFSBootMenu to lever you out of any holes that open up underneath your feet! :slight_smile: