FYI for anyone running Proxmox on a Dell or HP micro tower with a Realtek NIC

Obviously this is more for the homelab folks.

Be cautious upgrading to Proxmox 8. There’s a newer driver that doesn’t like some of the Realtek chipsets.

Here’s the fix that worked for me:

  1. Run lspci -v to make sure you’re actually running the problematic driver. (r8169, in this case.)

  2. Add the non-free debian repository to your sources.list and update your apt cache.

    • deb bookworm main non-free
  3. Make sure you have the pve-headers package installed. apt install pve-headers. For some reason this was missing on my system.

  4. Install the r8168-dkms package. apt install r8168-dkms

  5. Blacklist the r8169 driver. modprobe -r -v r8169

  6. Reboot.

  7. Run lspci -v again to make sure you’re running r8168 now.

Hopefully this saves someone the headache that I had yesterday.


That’s not even just v.8, its been an issue for a long time on Debian systems of all types. I had a friend that this fixed all sorts of problems on his Proxmox server.

I never had issues until I installed 8.

Update from December 2023:

Tried to update from proxmox 8.0.4 to 8.1.3 and it failed to install the new kernel due to the dkms module.

I uninstalled the module with apt remove r8168-dkms and removed the blacklist with rm /etc/modprobe.d/r8168.conf, and then i was able to update, and reboot into the new kernel.

Thus far the r8169 driver on the newer kernel seems to be stable, at least for the last couple hours. Hopefully I don’t get woken up in the middle of the night by things going offline.

1 Like